ここから本文です

Cisco1720同士で同一ネットワークにおけるスタティックルートの設定 度々の質問申...

このエントリーをはてなブックマークに追加

質問者

inugasukinanodesuさん

2010/5/1419:29:25

Cisco1720同士で同一ネットワークにおけるスタティックルートの設定
度々の質問申し訳ありません。

192.168.1.1から192.168.1.2へのスタティックルートの設定が
エラーになってしまいます。ping、telnetはOKです。

IPアドレス設定は以下の通りです。
Cisco1720 1台目(Ro-B)…FastEthernet0に192.168.1.1
Cisco1720 2台目(Ro-C)…FastEthernet0に192.168.1.2
※両方no shutdown済です。

ケーブル接続:
PCからRo-Bにコンソールケーブルにて接続。
Ro-BとRo-Cを10/100 ETHERNETポートを使用しクロスケーブルにて直結。

コマンドのログ:
Ro-B(config)#ip route 192.168.1.1 255.255.255.0 192.168.1.2
%Inconsistent address and mask

前回の質問でネットワークが違うとポートも変えないといけない事を
教えて頂きました。今回は192.168.1.xxx同士で同じネットワークのはず
なんですがうまくいきません。

-----Ro-Bのコンフィグ-----

Ro-B#sh run
Building configuration...

Current configuration : 632 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Ro-B
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$gOxZ$/IHERj.uebInL7Fr/LmyF0
enable password ciscocisco
!
memory-size iomem 25
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
speed auto
full-duplex
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password cisco
login
!
end

Ro-B#

-----Ro-Cのコンフィグ-----

Ro-C#sh run
Building configuration...

Current configuration : 728 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Ro-C
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$sd4E$AcM5azHkwcum9zeZorbvH.
enable password ciscocisco
!
memory-size iomem 25
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
isdn switch-type basic-5ess
!
!
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn switch-type basic-5ess
!
interface FastEthernet0
ip address 192.168.1.2 255.255.255.0
speed auto
full-duplex
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password cisco
login
!
end

Ro-C#

補足>ruthy36th様

再度回答頂き有難う御座います。スタティックルートの設定の意味を
分かっていなかったです。今回、自分がやろうとしてた同一ネットワークの
直結スタティックルート設定というのは、1720側からするとルーティングするまでも
ないのでエラーを返してきた、という認識でよろしいでしょうか。

閲覧数:
3,304
回答数:
2
お礼:
50枚

違反報告

ベストアンサーに選ばれた回答

ruthy36thさん

2010/5/1420:24:32

どうもたびたび現れました。

Ro-B(config)#ip route 192.168.1.1 255.255.255.0 192.168.1.2

この設定は変ですね。
スタティックルートに限りませんが、ルーティング設定というのは、
そのルータが知らないネットワークへの通信の宛先を指定する
ために設定するものです。

私が前の回答で書いた例を再度出しますと、
=====
端末A - Fe0【Ro-B】Fe1 - Fe1【Ro-C】Fe0 - 端末B

端末A:192.168.1.1
Ro-B Fe0:192.168.1.254
Ro-B Fe1:192.168.0.1
Ro-C Fe0:192.168.2.254
Ro-C Fe1:192.168.0.2 ←(ナオシマシタ)
端末B:192.168.2.1
=====

この時、Ro-Bには192.168.0.0/24と、192.168.1.0/24の
ネットワークが繋がっています。
なので、このネットワーク宛てのルートは既にRo-Bは
知っているので設定する必要はありません。
しかし、Ro-Cの先にある192.168.2.0/24のネットワークは
Ro-Bは知りません。
このため、そのままでは端末Aが端末BにPingを打とうと
しても行き先が分からないので届きません。

こういう時にスタティックルートで、

Ro-B(config)#ip route 192.168.2.0 255.255.255.0 192.168.0.2
<192.168.2.0/24宛ての通信はRo-Cに飛ばせ>

という設定を入れて、通信を導いてあげるわけです。

質問した人からのコメント

2010/5/14 23:44:18

詳細に説明頂き有難う御座います。1日がかりで悩んでいたので
助かりました。だいぶ物理的な接続のイメージが湧いてきました。
増設用の機器が届いたら、検証します!!

>ari_23_1226様
今、環境が無いのでルーティングテーブルを見られないですが
記載があれば設定出来る訳ないですよね。目から鱗でした!

ちょい足しを取り消しますが
よろしいですか?

  • 取り消す
  • キャンセル
  • このエントリーをはてなブックマークに追加
簡単にみんなで作るショート動画アプリ Yahoo!Chocotle for Android(無料)
ベストアンサー以外の回答
1〜1件/1件中

ari_23_1226さん

2010/5/1423:03:34

> 今回、自分がやろうとしてた同一ネットワークの
> 直結スタティックルート設定というのは、1720側からするとルーティングするまでも
> ないのでエラーを返してきた、という認識でよろしいでしょうか。

そもそもIPアドレスを設定した時点でshow ip routeコマンドをたたけば、どちらのルータでも、

C 192.168.1.0/24 is directly connected, FastEthernet0

のように表示されませんか?
IPアドレスを設定した時点ですでに直接接続されたネットワークのルーティングテーブルを持っているはずですが

ちょい足しを取り消しますが
よろしいですか?

  • 取り消す
  • キャンセル

Q&Aをキーワードで検索:

Yahoo! JAPANは、回答に記載された内容の信ぴょう性、正確性を保証しておりません。
お客様自身の責任と判断で、ご利用ください。
本文はここまでです このページの先頭へ

ID/ニックネームを選択し、「追加する」ボタンを押してください。

閉じる

※知恵コレクションに追加された質問や知恵ノートは選択されたID/ニックネームのMy知恵袋で確認できます。

ほかのID/ニックネームで利用登録する