ここから本文です

Cisco1720同士でスタティックルートの設定がうまくいきません 192.168.1.1から1...

このエントリーをはてなブックマークに追加

質問者

inugasukinanodesuさん

2010/5/1411:49:55

Cisco1720同士でスタティックルートの設定がうまくいきません

192.168.1.1から192.168.2.1へのスタティックルートの設定が
エラーになってしまいます。192.168.1.1から2へのpingも通りません。

IPアドレス設定は以下の通りです。
Cisco1720 1台目(Ro-B)…FastEthernet0に192.168.1.1
Cisco1720 2台目(Ro-C)…FastEthernet0に192.168.2.1
※両方no shutdown済です。

ケーブル接続:
PCからRo-Bにコンソールケーブルにて接続。
Ro-B→(ストレートケーブル)→スイッチングハブ→(ストレート)→Ro-C
(又はRo-BとRo-Cを10/100 ETHERNETポートを使用しクロスケーブルにて直結)。
※ハブを間に挟むのが悪いのかと思いクロスケーブル直結も試しましたが事象変わらず。

コマンドのログ:
Ro-B(config)#ip route 192.168.1.1 255.255.255.0 192.168.2.1
%Inconsistent address and mask

-----Ro-Bのコンフィグ-----

Ro-B#sh run
Building configuration...

Current configuration : 614 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Ro-B
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$gOxZ$/IHERj.uebInL7Fr/LmyF0
enable password ciscocisco
!
memory-size iomem 25
no aaa new-model
ip subnet-zero
!
!
!
ip cef
!
!
!
!
!
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
speed auto
full-duplex
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 20 30
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password cisco
login
!
end

-----Ro-Cのコンフィグ-----

Ro-C#sh run
Building configuration...

Current configuration : 669 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Ro-C
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$sd4E$AcM5azHkwcum9zeZorbvH.
enable password ciscocisco
!
memory-size iomem 25
no aaa new-model
ip subnet-zero
!
!
!
ip cef
!
isdn switch-type basic-5ess
!
!
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn switch-type basic-5ess
!
interface FastEthernet0
ip address 192.168.2.1 255.255.255.0
speed auto
full-duplex
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
end

Ro-C#

閲覧数:
1,759
回答数:
1
お礼:
50枚

違反報告

ベストアンサーに選ばれた回答

ruthy36thさん

2010/5/1413:08:57

これは・・・・・もしかしてRo-BのFe0と、Ro-CのFe0を接続しようとしているのでしょうか?
それはもちろん通らないですよ?ネットワークが違うので。
やりたいのであれば、

端末A - Fe0【Ro-B】Fe1 - Fe1【Ro-C】Fe0 - 端末B

のような構成にして、

端末A:192.168.1.1
Ro-B Fe0:192.168.1.254
Ro-B Fe1:192.168.0.1
Ro-C Fe0:192.168.2.254
Ro-C Fe0:192.168.0.2
端末B:192.168.2.1

という風にアドレス設計をする必要があります。
いくらルータでも、直結されている異なるネットワーク宛てに
通信は出せません……。

質問した人からのコメント

2010/5/14 16:03:50

回答有難う御座います。例えルータ同士でも違うネットワークに属する
ポート同士を繋ぐ事は出来ないんですね!
現状、Cisco1720には2台とも10/100 ETHERNETポートが1つずつしか無く
注文したWIC-1ENET×2が届くのを待っている段階です。届き次第増設して
教えて頂いた方法をやってみます!!
後、Ro-C Fe0:192.168.0.2はRo-C Fe1:192.168.0.2ですよね?

ちょい足しを取り消しますが
よろしいですか?

  • 取り消す
  • キャンセル
  • このエントリーをはてなブックマークに追加
簡単にみんなで作るショート動画アプリ Yahoo!Chocotle for Android(無料)

Q&Aをキーワードで検索:

Yahoo! JAPANは、回答に記載された内容の信ぴょう性、正確性を保証しておりません。
お客様自身の責任と判断で、ご利用ください。
本文はここまでです このページの先頭へ

ID/ニックネームを選択し、「追加する」ボタンを押してください。

閉じる

※知恵コレクションに追加された質問や知恵ノートは選択されたID/ニックネームのMy知恵袋で確認できます。

ほかのID/ニックネームで利用登録する