ここから本文です

ネットワークエンジニアの方に質問があります!CiscoのL3SWとL2SWでVLAN間ルーティ...

lun********さん

2010/8/2209:38:31

ネットワークエンジニアの方に質問があります!CiscoのL3SWとL2SWでVLAN間ルーティングを実施する場合、以下のコマンドでホストAとホストBでpingが通りますか?

構成図が見にくいかもしれませんので文字でも書きます。

L3SW
|←-----------------------トランクリンクに設定

L2SWーホストB(VLAN20)


ホストA(VLAN10)

VLAN間ルーティングをしてpingを飛ばしたいです。

■L2SW(Switch_A)に設定

Switch#conf t
Switch(config)#hostname Switch_A
Switch_Aconfig)#exit
Switch_A#vlan database
Switch_A(vlan)#vlan 10 name vlan10
Switch_A(vlan)#vlan 20 name vlan20
Switch_A(vlan)#exit
Switch_A#config t
Switch_A(config)#int f0/1
Switch_A(config-if)#switchport mode access
Switch_A(config-if)#switchport access vlan 10
Switch_A(config-if)#int f0/2
Switch_A(config-if)#switchport mode access
Switch_A(config-if)#switchport access vlan 20
Switch_A(config-if)#int f0/9
Switch_A(config-if)#switchport mode trunk
Switch_A(config-if)#switchport nonegotiate

■L3SW(Switch_B)に設定
http://ccstudy.org/study/vlan/vlanroute3/vlanroute3.html
↑を参考にしました。(ほとんどマネですけど・・・)

Switch_B# ip routing
Switch_B#interface FastEthernet0/1
Switch_B(config-if) switchport access vlan 10 ←このポートをVLAN10に所属させる
Switch_B(config-if)switchport mode trunk
no ip address
!
interface FastEthernet0/2
switchport access vlan 20 ←このポートをVLAN20に所属させる
switchport mode trunk
no ip address
!
interface Vlan1
no ip address
shutdown
!
SwitchA#interface Vlan10
SwitchA(config-if)#ip address 192.168.0.254 255.255.255.0
!
SwitchA#interface Vlan20
SwitchA(config-if)#ip address 192.168.1.254 255.255.255.0

SwitchA(config)#interface vlan 10
SwitchA(config-if)#ip address 192.168.0.254 255.255.255.0


SwitchA(config)#interface vlan 20
SwitchA(config-if)#ip address 192.168.1.254 255.255.255.0

どうでしょうか?これでVLAN間ルーティングはできそうですか?

お礼はコイン全部の50枚です!

詳しい方、どうかアドバイスいただけないでしょうか?

ヘルプミー!!

閲覧数:
1,892
回答数:
1
お礼:
50枚

違反報告

ベストアンサーに選ばれた回答

hia********さん

2010/8/2310:23:50

これだとだめです。
まず、SwitchB(L3)にVLANインターフェイスを作成(Vlan10と20)し、IPを割り当てて下さい。(質問文だと何故かSwitchAに割り当ててますね。)
SwitchAはL2SWですよね?なので、VLAN間ルーティングをするためにIPを割り当てる必要はないです。(telnetを利用したい等の理由があれば設定する必要がありますが)
また、L3SWとL2SWを接続するL3SW側のポートは何番ですか?仮にFastethernet0/1だとすると、
Switch_B#interface FastEthernet0/1
Switch_B(config-if)switchport mode trunk
だけでいいです。
わざわざswitchport access vlan 10は要りません。

質問した人からのコメント

2010/8/23 23:10:00

hiaya1002さん
回答ありがとうございます!本日、会社の先輩からテストらしきものをやって、なんとか解決できました。いただいた回答でさらに理解が深まりました。

あわせて知りたい

この質問につけられたタグ

みんなで作る知恵袋 悩みや疑問、なんでも気軽にきいちゃおう!

Q&Aをキーワードで検索:

Yahoo! JAPANは、回答に記載された内容の信ぴょう性、正確性を保証しておりません。
お客様自身の責任と判断で、ご利用ください。
本文はここまでです このページの先頭へ

「追加する」ボタンを押してください。

閉じる

※知恵コレクションに追加された質問は選択されたID/ニックネームのMy知恵袋で確認できます。

不適切な投稿でないことを報告しました。

閉じる