ここから本文です

ホームページに載せた画像が表示されません。転送時には問題なく、ファイル名も半...

pai********さん

2008/4/1819:47:22

ホームページに載せた画像が表示されません。転送時には問題なく、ファイル名も半角で、ホームページ用のフォルダに入れています。同じフォルダの他の画像はちゃんと表示されていて、特定の画像だけが表示されません

表示されない画像は、一つのページにある三つの画像だけで、他のページの画像は表示されています。何故か特定のページにある画像だけ表示されません。原因が分かる方はいないでしょうか?

閲覧数:
307
回答数:
3
お礼:
100枚

違反報告

ベストアンサーに選ばれた回答

tow********さん

2008/4/1821:24:31

ホームページを見ていないので断言は出来ませんが
考えられる原因として

・リンク元のHTMLタグに誤りがある
<a href="***.jp">となっていますか?

・画像ファイルがアップロードした別のフォルダに入っていてタグが
<a href="image/abc.jpg">等になっていない

index.html
xxxxx.html
[image]フォルダ-abc.jpg

・.htaccessで制限がかかっている
・プラウザで認識できない拡張子


ブラウザのツール>インターネットオプション>一時ファイルの削除 も試してみてください。

質問した人からのコメント

2008/4/19 13:01:32

驚く 回答有難う御座いました!
どうやらかなり初歩的なミスをしていたようです。ファイル名に±と〆が入っていました。やっぱりファイル名は自分でよく見てつけたほうが良かったです。
ベストアンサーは、タグを確認していてファイル名の使えない記号を見つけたので、かなり迷いましたが、townsideさんの回答にさせて頂きました。
皆さんどうも有難うございました。

ベストアンサー以外の回答

1〜2件/2件中

並び替え:回答日時の
新しい順
|古い順

mag********さん

2008/4/1910:32:59

そこまで判っているなら設定に問題は無さそうですね・・・
何かホームページ作成ソフトを使用していますか?作成ソフトから画像の貼り付け(取り込み)を行うと、稀に
個人ユーザーフォルダが先頭に付加されるケースがあります。(別のパソコンで作成したりすると)

例えばマイドキュメント(フォルダ)内にHPを作成している場合
<img scr="/c:User/aaa/Documents/・・・・○○○.jpg">←パソコン固有のパスがセットされる。

/c:User/aaa/Documents/ ← これがあったら消して、サーバー内と同じファルダから指定して下さい。
(パソコン内でHTMLを実行すると表示されるが、サーバーに転送すると表示されない)

↑は一つの可能性としてですが、やはり設定したパスが間違っているように思えますので、再度確認してみて下さいね。(^^;

m0o********さん

2008/4/1822:41:19

>表示されない画像は、一つのページにある三つの画像だけで、他のページの画像は表示されています。何故か特定のページにある画像だけ表示されません。
その一つのページ(a.html)と他のページ(b.html)は同じ階層にありますか?
例えば、index.htmlとa.htmlが同階層にあり、aa.jpg、bb.jpgの画像がimageというフォルダにあるとします。
次に別にabcというフォルダがありその中にb.htmlがあるとしますと、画像表示は
a.htmlにおいては、<img src="image/aa.jpg" width=""・・・・・・・・・・>となり
b.htmlにおいては、<img src="../image/bb.jpg"・・・・・・・・・・・・・・・・>というふうになりますが、その辺はどうでしょうか?

この質問につけられたタグ

みんなで作る知恵袋 悩みや疑問、なんでも気軽にきいちゃおう!

Q&Aをキーワードで検索:

Yahoo! JAPANは、回答に記載された内容の信ぴょう性、正確性を保証しておりません。
お客様自身の責任と判断で、ご利用ください。
本文はここまでです このページの先頭へ

「追加する」ボタンを押してください。

閉じる

※知恵コレクションに追加された質問は選択されたID/ニックネームのMy知恵袋で確認できます。

不適切な投稿でないことを報告しました。

閉じる