ここから本文です

MacOSX上pip3のパスとなるフォルダがpython2を参照している問題。 環境はMacOSX...

kot********さん

2017/2/1318:00:05

MacOSX上pip3のパスとなるフォルダがpython2を参照している問題。

環境はMacOSX、python2.7とpython3.5.2を入れ、各々のpipも入っています。

$python --version #Python 2.7.10
$python3 --version #Python3.5.2
$pip --version
#pip 9.0.1 from /Library/Python/2.7/site-packages (python 2.7)

まではいいのですが、
$pip3 --version
#pip 9.0.1 from /usr/local/lib/python2.7/site-packages (python 2.7)
となってしまっています。

初心者でパスなどに関して詳しくありません。
どうぞ助言をよろしくお願いします。

閲覧数:
37
回答数:
1
お礼:
50枚

違反報告

ベストアンサーに選ばれた回答

プロフィール画像

カテゴリマスター

バッキーさん

2017/2/1419:21:11

python2.7と python3.5をどのような方法でインストールしたのか、
現在の実行環境(環境変数、特に Path)がどのようになっているのか、
が分からないと、誰もどうしていいか回答できないと思います。

それと、Pathが分からないとどうしようもないので、まずは Pathについて勉強なさってみてください。

Pathが理解できれば、自ずと問題点も判ると思います。

この回答は投票によってベストアンサーに選ばれました!

みんなで作る知恵袋 悩みや疑問、なんでも気軽にきいちゃおう!

Q&Aをキーワードで検索:

Yahoo! JAPANは、回答に記載された内容の信ぴょう性、正確性を保証しておりません。
お客様自身の責任と判断で、ご利用ください。
本文はここまでです このページの先頭へ

「追加する」ボタンを押してください。

閉じる

※知恵コレクションに追加された質問は選択されたID/ニックネームのMy知恵袋で確認できます。

不適切な投稿でないことを報告しました。

閉じる