ここから本文です

pythonについての質問です

アバター

ID非公開さん

2018/3/712:41:23

pythonについての質問です

プログラミングかなりの初心者です。
pipのinstallがうまくいきません。
コマンドラインに
pip3 install pillow qrcode
と打ったのですが、しばらくすると
could not find a version that satisfies the requirement pillow (from versions:)
No matching distribution found for pillow

と出てきてしまいます。
もし解決方法が分かる方がいらっしゃいましたら、ご回答よろしくお願いいたします。

閲覧数:
35
回答数:
2
お礼:
100枚

違反報告

ベストアンサーに選ばれた回答

kid********さん

2018/3/801:40:51

pipでディストリビューションが見つからない場合、pypi.python.orgで調べてみてください。
その際、pythonバージョンとOSアーキテクチャの2点は要確認項目です。
Pillow最新バージョン5.0は、pillow.readthedocs.ioにもあるとおりpythonバージョン2.7,3.4,3.5,3.6をサポートし、pypiに登録されているようです。

あとは、念のためですが
小文字pillowではなく、
大文字Pillowを試してみてはどうでしょうか、pip install Pillowの手順がreadthedocsに記載されています。

アバター

質問した人からのコメント

2018/3/11 18:39:36

解決策をお考えくださり、ありがとうございました!
doveさんの案を基として考えていった結果、管理者アカウントではないサブアカウントユーザーとしてパソコンにログインしていたのが良くなかったのかと思い、何とか解決することが出来ました。
本当にありがとうございました!

ベストアンサー以外の回答

1〜1件/1件中

kat********さん

2018/3/723:33:01

pythonのバージョンによる問題だと思いますが、
python3.6.4でも正常にインストールできるので
問題の特定はできませんでした。

みんなで作る知恵袋 悩みや疑問、なんでも気軽にきいちゃおう!

Q&Aをキーワードで検索:

Yahoo! JAPANは、回答に記載された内容の信ぴょう性、正確性を保証しておりません。
お客様自身の責任と判断で、ご利用ください。
本文はここまでです このページの先頭へ

「追加する」ボタンを押してください。

閉じる

※知恵コレクションに追加された質問は選択されたID/ニックネームのMy知恵袋で確認できます。

不適切な投稿でないことを報告しました。

閉じる