ここから本文です

ruby on railsのチュートリアルをしています。

pur********さん

2019/2/610:37:49

ruby on railsのチュートリアルをしています。

https://railsguides.jp/getting_started.html

環境構築は以下で行い、無事に完遂することができました。
https://qiita.com/TAByasu/items/47c6cfbeeafad39eda07

ところが、復習のために新たにプロジェクト (rails new ) をしたところ、
rails server をすると localhost:3000 のブラウザにて、
以下のエラーが出るようになってしまいました。

Puma caught this error: Error loading the 'sqlite3' Active Record adapter. Missing a gem it depends on? can't activate sqlite3 (~> 1.3.6), already activated sqlite3-1.4.0. Make sure all dependencies are added to Gemfile. (LoadError)

心当たりとすれば、それまで何度か rails new でフォルダを作って練習してきましたが、チュートリアルが一通り終わったので、できたアプリフォルダを finder上から全部けしたことです。
作ったアプリフォルダをまっさらにして、新たに作ったところ、rails s でこのようなエラーがでたような感じです。

修正の心当たりのあるかた、よろしくお願いいたします。

補足エラーメッセージによると、sqlite3に関するgemが無いような意味に受け取れますが、

gem list をすると

sqlite3 (1.4.0, 1.3.13) と出ます。

Ruby 2.5.0
Rails 5.2.2

です。

ついこないだ迄普通に rails server が立ち上がって、チュートリアルも無事できたのに、突然このようなエラーが出てしまいました。

閲覧数:
38
回答数:
1
お礼:
500枚

違反報告

ベストアンサーに選ばれた回答

プロフィール画像

カテゴリマスター

cd6********さん

2019/2/618:40:21

Rails 側は暗に sqlite3 の 1.3 系を要求してるのに Gemfile に
バージョン指定してないので 1.4.0 が呼ばれてるという状況です。
Gemfile で
gem 'sqlite3', '~> 1.3.6'
とエラーのサジェスチョンどおりに修正しましょう。

  • 質問者

    pur********さん

    2019/2/707:33:27

    ご回答ありがとうございます。
    無事治すことができました。

    原因を調べた結果、
    2019年2月5日に sqlite3の1.4が追加されたそうですが、まだ対応していないのでエラーが出るようでした。

    以下のページの通りのインストールで修正できました。
    https://qiita.com/shita_fontaine/items/aa3f762d7afa20c5d42a

    ありがとうございます。

返信を取り消しますが
よろしいですか?

  • 取り消す
  • キャンセル

質問した人からのコメント

2019/2/7 07:34:01

ありがとうございます。

みんなで作る知恵袋 悩みや疑問、なんでも気軽にきいちゃおう!

Q&Aをキーワードで検索:

Yahoo! JAPANは、回答に記載された内容の信ぴょう性、正確性を保証しておりません。
お客様自身の責任と判断で、ご利用ください。
本文はここまでです このページの先頭へ

「追加する」ボタンを押してください。

閉じる

※知恵コレクションに追加された質問は選択されたID/ニックネームのMy知恵袋で確認できます。

不適切な投稿でないことを報告しました。

閉じる