ID非公開

2022/7/5 0:38

33回答

キーボードから読み込んだ整数の段数をもつ下図を表示するプログラムを作成せよ. ******* ***** *** * この問題の解答を教えてください。 よろしくお願いします。

C言語関連62閲覧xmlns="http://www.w3.org/2000/svg">50

ベストアンサー

0

ThanksImg質問者からのお礼コメント

回答ありがとうございました!

お礼日時:7/5 4:18

その他の回答(2件)

0

#include <stdio.h> int main(void){ void Print(int x); int x; scanf("%d",&x); Print(x); } void Print(int x){ if(x <= 0) return; for(int i = 0; i < 2*x-1; i++){ printf("*"); } printf("\n"); Print(x-1); } "*"の数は下から1,3,5,7といったように、x行目では2x-1個"*"があり、数列になっています。 これを順に書けばよいのでPrintの再起関数でxを1つずつ減らしながら2x-1個出力していきます。 もっと簡単に、 for(int i = x; i > 0;i--){ for(int j = 0; j < 2*i-1; j++){ printf("*"); } printf("\n"); } でもいいですが。

0

負の数が入力された場合はどのように表示すればよいのでしょうか?

ID非公開

質問者2022/7/5 1:59

回答ありがとうございます。 正の整数のみでお願いします。