ここから本文です

IPsecを導入するために#apt-get install openswanをしたのですが、package openswa...

fx_********さん

2015/11/1916:00:02

IPsecを導入するために#apt-get install openswanをしたのですが、package openswan is not availableとエラーが出て入れられません。

#apt-get updateも行いましたが同じエラーが出ます。

openswanのパッケージリストを/etc/apt/sources.listに追加すれば良いと思うのですが具体的にどうすればいいのかわかりません。

閲覧数:
127
回答数:
1
お礼:
100枚

違反報告

ベストアンサーに選ばれた回答

プロフィール画像

カテゴリマスター

2015/11/1916:30:34

実は、openswan は、2.6 カーネルまでしかサポートしていません!
カーネルが、3.X 以上では、別の IPSec の実装を使います。
RedHat 系では、
libreswan というのを使っています。
しかし、libreswan は、何故か Debian 系では、パッケージが作成されていません。
ソースからビルドすることは、できます。
しかし、それは、面倒なので、同等の事が出来る
strongswan なら、パッケージがあるので、それを使ってだめなら
ソースから、libreswan を入れてみましょう。

https://www.manabii.info/2014/08/debian-wheezy-strongswan-l2tp-ipse...

この回答は投票によってベストアンサーに選ばれました!

みんなで作る知恵袋 悩みや疑問、なんでも気軽にきいちゃおう!

Q&Aをキーワードで検索:

Yahoo!知恵袋カテゴリ

一覧を見る

Yahoo! JAPANは、回答に記載された内容の信ぴょう性、正確性を保証しておりません。
お客様自身の責任と判断で、ご利用ください。
本文はここまでです このページの先頭へ

「追加する」ボタンを押してください。

閉じる

※知恵コレクションに追加された質問は選択されたID/ニックネームのMy知恵袋で確認できます。

不適切な投稿でないことを報告しました。

閉じる