ここから本文です

クライアントよりODBC経由でPostgreSQL9.1.1に更新処理を行う際に、 ある特定の文...

kazuyakoretsuneさん

2017/7/1910:54:04

クライアントよりODBC経由でPostgreSQL9.1.1に更新処理を行う際に、
ある特定の文字列で以下エラーがでました。

エラー内容>
odbc escape convert error

特定の文字列>
ミナミ施

現在把握していること>
①半角文字を一文字減らせば更新処理可能。
②全角文字を減らせば更新処理可能。
③PostgreSQLをPGAdminでは更新可能。
④ODBC経由で更新した場合更新不可
※ ドットネット製品もしくは、A5:SQLツール

何か有力な情報があれば教えてください。

閲覧数:
31
回答数:
1
お礼:
25枚

違反報告

ベストアンサーに選ばれた回答

bm5mz3さん

2017/7/1915:43:30

postgresql.confに
standard_conforming_strings = off
を追加してみる

この質問は投票によってベストアンサーに選ばれました!

みんなで作る知恵袋 悩みや疑問、なんでも気軽にきいちゃおう!

Q&Aをキーワードで検索:

Yahoo! JAPANは、回答に記載された内容の信ぴょう性、正確性を保証しておりません。
お客様自身の責任と判断で、ご利用ください。
本文はここまでです このページの先頭へ

「追加する」ボタンを押してください。

閉じる

※知恵コレクションに追加された質問や知恵ノートは選択されたID/ニックネームのMy知恵袋で確認できます。