ここから本文です

いつもお世話になります。

mar********さん

2017/3/1120:12:57

いつもお世話になります。

ubuntu16.04ltsをwindowsにクリーンインストールしてwebサーバにしたいのですが、apache2はインストールできましたが、
php5や5.6がインストールできません。php5は依存関係ツリーでエラーになり、5.6ではインストールできません。php7はバグがあるのでよくないと聞きましたし、apache2で使えるのかも分かりません。
よろしくご指導ください。
xubuntu-16.04.2-desktop-i386.isoをインストールしました。

補足ネットで調べて以下のコマンドでphp5.6がインストールできましたが問題なかったでしょうか。
sudo add-apt-repository ppa:ondrej/php
sudo apt update
sudo apt install php5.6

閲覧数:
117
回答数:
2
お礼:
50枚

違反報告

ベストアンサーに選ばれた回答

kei********さん

2017/3/1217:49:17

usermod -G www-data hoge

これやると、ユーザーhogeが所属するグループがwww-data「だけ」になってしまう(それまで所属していた他のグループは全て消される)のですが、その辺の問題は生じていないのでしょうか?

  • 質問者

    mar********さん

    2017/3/1809:43:40

    keicha_hrsさん、ありがとうございます。

    よくわかりませんのです・・・。
    社内のイントラネットでwebサーバの仕組みを利用してファイルの共有やコミュニケーション等で活用することを目的に使っています。
    サーバはwindouws proでやってますが、これをubuntuに移行したいと考えています。
    クライアントは他のwindouws PCです。サーバをさわるのは私だけです。
    その際に、コマンドが何か影響する可能性があるということでしょうか?
    よろしくお願いいたします。

  • その他の返信(4件)を表示

返信を取り消しますが
よろしいですか?

  • 取り消す
  • キャンセル

この回答は投票によってベストアンサーに選ばれました!

ベストアンサー以外の回答

1〜1件/1件中

rona-tombowさん

2017/3/1122:52:39

sudo apt install apache2
sudo apt install php
apt-cache show | grep php

の実行結果を返信して下さい
エラーの内容がわかりません

返信を取り消しますが
よろしいですか?

  • 取り消す
  • キャンセル

みんなで作る知恵袋 悩みや疑問、なんでも気軽にきいちゃおう!

Q&Aをキーワードで検索:

Yahoo!知恵袋カテゴリ

一覧を見る

Yahoo! JAPANは、回答に記載された内容の信ぴょう性、正確性を保証しておりません。
お客様自身の責任と判断で、ご利用ください。
本文はここまでです このページの先頭へ

「追加する」ボタンを押してください。

閉じる

※知恵コレクションに追加された質問は選択されたID/ニックネームのMy知恵袋で確認できます。

不適切な投稿でないことを報告しました。

閉じる