ここから本文です

php-mysqlのインストールでエラーになります.教えてください. CentOS6.5にphp...

got********さん

2015/6/1914:49:03

php-mysqlのインストールでエラーになります.教えてください.

CentOS6.5にphp-mysqlをインストールしようとしています.

yum --enablerepo=remi install -y php php-mbstring


下記のエラーメッセージの

パッケージ mysql-libs は mysql-community-libs によって不要になりました。しかし、不要のパッケージは要求を提供していません。
--> 依存性解決を終了しました。
エラー: パッケージ: php-mysql-5.4.42-1.el6.remi.x86_64 (remi)
要求: libmysqlclient.so.18(libmysqlclient_16)(64bit)
利用可能: mysql-libs-5.5.43-1.el6.remi.x86_64 (remi)
libmysqlclient.so.18(libmysqlclient_16)(64bit)
利用可能: mysql-libs-5.5.44-1.el6.remi.x86_64 (remi)
libmysqlclient.so.18(libmysqlclient_16)(64bit)
利用可能: mysql-libs-5.1.73-3.el6_5.i686 (base)
見つかりません
問題を回避するために --skip-broken を用いることができません
となります.

phpのバージョンは
$ php -v
PHP 5.4.42
となっています.

5.4.42-1.el6 が無いと言われているところはわかりますが,
どうしたらいいのでしょうか.


yum install -y php php-mbstring
と--enablerepo=remiを取ってみると
エラー: パッケージ: php-mysql-5.3.3-40.el6_6.x86_64 (updates)
要求: php-common(x86-64) = 5.3.3-40.el6_6
エラー: パッケージ: php-pdo-5.3.3-40.el6_6.x86_64 (updates)
要求: php-common(x86-64) = 5.3.3-40.el6_6
と言われてしまいました.



php-mysqlのインストールを忘れて,先にmysqlをインストールしてしまいました.

閲覧数:
2,398
回答数:
1
お礼:
100枚

違反報告

ベストアンサーに選ばれた回答

プロフィール画像

カテゴリマスター

編集あり2015/6/1919:50:19

今、やってみました。
yum で指定する名前が間違っているのでは?

yum --enablerepo=remi install -y php54 php54-php php54-php-mbstring php54-php-mysql

ちなみに、
alternatives --display php
とやると、
現在の「最適」バージョンは /usr/bin/php54 です。
と出ますね。

返信を取り消しますが
よろしいですか?

  • 取り消す
  • キャンセル

質問した人からのコメント

2015/6/23 17:16:33

ありがとうございました.

php54-gdをインストールしたのですが, php54 -mで表示されません.
このあたりは,もう少し調べてみます.

この質問につけられたタグ

みんなで作る知恵袋 悩みや疑問、なんでも気軽にきいちゃおう!

Q&Aをキーワードで検索:

Yahoo!知恵袋カテゴリ

一覧を見る

Yahoo! JAPANは、回答に記載された内容の信ぴょう性、正確性を保証しておりません。
お客様自身の責任と判断で、ご利用ください。
本文はここまでです このページの先頭へ

「追加する」ボタンを押してください。

閉じる

※知恵コレクションに追加された質問は選択されたID/ニックネームのMy知恵袋で確認できます。

不適切な投稿でないことを報告しました。

閉じる