ここから本文です

回答受付終了まであと3日 回答を投稿すると知恵コイン15枚が追加されます

Xamarin で Android のアプリ開発をしています。

mrbaberuさん

2017/3/2002:47:47

Xamarin で Android のアプリ開発をしています。

エミュレータは使用せず、Zenfone3 でデバッグしながら開発していたのですが、
Visual Studio 上で Zenfone3 が認識されなくなりました。
※「adb devices」 コマンドでアタッチは確認出来ます
※デバイス側は「USBデバッグが接続されました」と表示されます

解決方法がわかる方がいらっしゃいましたらご回答をお願いいたします。

【試した事】
・プロジェクトの開きなおし
・Visual Studio の再起動
・OSの再起動
・SDK Manager から諸々アップデートやインストール

【開発環境】
・Windows 10 Home
・Visual Studio Community 2015
・Xamarin.Android
・Zenfone3 (Android 7.0 にアップデート済み)


Visual Studio のプロジェクトロード時に以下が出力されます。
(出力元:Xamarin Diagnotics )
-------------------------------------------------------------------------------------
[I:]: Tracking android devices started
[D:]: Tracking avd started
[D:]: avd watcher *.ini path: 'C:\Users\Yu\.android\avd'
[D:]: avd watcher android path: 'C:\PROGRA~2\Android\ANDROI~1\tools\android.bat'
[D:]: TrackDeviceTask got: G7AZCY00D142N49 device
[I:]: Got new device list from adb with 1 devices
[D:RunShellCommand]: G7AZCY00D142N49 getprop
[D:RunShellCommand]: G7AZCY00D142N49 getprop
[D:]: avd watcher: got device list from avd with 0 devices
-------------------------------------------------------------------------------------

補足多分、これが原因かな。
http://santea.hateblo.jp/entry/2016/09/10/180918

閲覧数:
17
回答数:
0
お礼:
250枚

違反報告

回答投稿

全角10文字以上で回答を入力してください。

※質問が「投票受付中」「解決済み」になると、回答を取り消すことはできません。
※一度に投稿できるURLは3つ以内です。(プレミアム会員除く)

エラーが発生しました。お手数ですが、時間をおいて再度お試しください。

あと全角4000文字

みんなで作る知恵袋 悩みや疑問、なんでも気軽にきいちゃおう!

Q&Aをキーワードで検索:

Yahoo! JAPANは、回答に記載された内容の信ぴょう性、正確性を保証しておりません。
お客様自身の責任と判断で、ご利用ください。
本文はここまでです このページの先頭へ

「追加する」ボタンを押してください。

閉じる

※知恵コレクションに追加された質問や知恵ノートは選択されたID/ニックネームのMy知恵袋で確認できます。