ThinkPad x220を中古で購入しました。osは素のwindows xpをインストールしたのですが、当然ながらインターネット接続に必要なドライバーはインストールされていない状態です。

補足

現役のXPからドライバを抜き出すとか、USBのLANを試してみるとか建設的な意見はないようですね。

パソコン | Windows XP49閲覧xmlns="http://www.w3.org/2000/svg">500

ベストアンサー

1

1人がナイス!しています

ThanksImg質問者からのお礼コメント

否定と批判ばかりの輩とは違い、建設的なコメントをして下さり救われました。ありがとうございます。

お礼日時:3/29 11:09

その他の回答(5件)

0

Lenovoのサイトからダウンロード出来るはずです。 又は軽量LinuxをインストールしてSysinfoインストールしてデバイス名を読み出し、チップメーカからダウンロードすれば良い。

「現役のXPからドライバを抜き出すとか、USBのLANを試してみるとか建設的な意見はないようですね。」 批判するより自分で用意するもの。 ThinkPadシリーズはインサーネットコントローラーは簡単に接続できる。 ワイヤレスドライバーは内蔵無線LAN子機が数種類あり裏蓋を外して確認するか軽量Linuxで確認するかです。 中古を買う人なら「現役のXPからドライバを抜き出すとか」出来ない事は常識です。 ThinkPadシリーズのリカバリーディスクを用意できる見込みが無ければ手を出すものでは無いのです。

1

そもそもXPは2014年にセキュリティサポート終わってるわけだし、普通はネット接続しようさせようだなんて考えないもんですが。 ジャンクに手出しできるのは一定スキルのある覚悟のある人のみ。

1人がナイス!しています

0

ありませんb(^-^ 現実逃避しようが妄想しようがないものはないんです。 現実的な話をするなら以下のサイトをご覧になり受け止めてくださいq(.. https://pcsupport.lenovo.com/at/ja/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x220/downloads/driver-list WindowsXPというオペレーティングシステムをハードウエアがサポートしていないとなれば、無いものはないとしか言いようがありません。 仮想環境でOSインストールとかいう屁理屈をこねても、ハードウエアに対応するデバイスドライバーが無ければ、ほぼ、どのデバイスも動かないセーフモードのパソコンとしてしか起動しないはずです。 VM Ware Virtualbox など。

補足 ただ、自分で調べようともしないで建設的な意見とか言われても説得力ないですね。 WindowsXPが発売された2001年当時のインストールディスクに、10年後に発売された質問者様がお使いの当時存在しないパソコンのNICドライバを予想して作ることはできないんですから、入っているわけがないという現実をまだ受け止められませんかね? 要するに過去のOSから未来の存在しないデバイスドライバが入っているという妄想を膨らませるのはもはや現実逃避でしかありませんので、冒頭の通りないものはないと言っているわけです。 OSの仕組みやハードウエアを理解していればこのようなご質問はされないと思います。 そんなにWindowsXPを使いたいならそんな新しい期待ではなく、当時の古い実機を用意してくださった方が良いと思いますよ。 仮想環境でも当然ドライバが無ければ認識しません。

0

最低限インターネット接続に必要なドライバー名を教えて下さい> XPじゃすでにドライバは入手不可能。 ってか、ネットに接続出来ない状態なのにどうやってネットからドライバを入手するの? (他にネット接続可能なPCがあるからの質問だとは思うけど…) ネット利用するならLinuxなどのフリーOSを利用した方が手間も掛からないし安全ですよ。

現役のXPからドライバを抜き出すとか> LANチップが必ずしも同じ物ではありませんし、その発想があるなら現役で動作しているXPがあるならドライバを自身で確認して抜き出せば良いじゃん… (質問を見る限りでは新規インストールしたXPのみで他に動作しているXP機は無いものとしてこちらは回答しているに過ぎません) USBのLANを試してみるとか> それにもドライバが必要です。 XP時代のOS標準ドライバは無いに等しいので、必ずドライバが必要になります。 それにXP時代はUSB接続のLANポートは速度も遅く実用的では無かった為に存在しませんでした。 現行のUSB接続LANポートは当然XP対象外ですから、付属ドライバは使用できません。